summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorŁukasz Pożarlik2022-02-02 09:04:17 +0100
committerŁukasz Pożarlik2022-02-02 09:04:17 +0100
commit74655b36621ed078b1d1474cb5e0602d0a73bef0 (patch)
tree04b0a3072d0302a3b38f382a7932d934151b27a4 /PKGBUILD
parentdc7a1dd6f4263fc8944944b7ffed5f705101460a (diff)
downloadaur-python-habitipy.tar.gz
Drop python2 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 940f1ab4803d..f250351e6f2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_name="habitipy"
_module="$_name"
-pkgname=("python-$_module" "python2-$_module")
+pkgname=("python-$_module")
pkgdesc="A set of scripts to interact with Habitica"
pkgver="0.3.0"
-pkgrel=4
+pkgrel=5
url="https://github.com/ASMfreaK/habitipy"
license=('MIT')
arch=('any')
-makedepends=("python-pbr>=1.9" "python2-pbr>=1.9")
+makedepends=("python-pbr>=1.9")
source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
"LICENSE")
sha256sums=('6b2d01eab4da0b2b78280ce0f670c5f7b4c249e1b0794e544fa1f2f4d07ec2a3'
@@ -30,12 +30,3 @@ package_python-habitipy(){
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
}
-
-package_python2-habitipy(){
- depends=("python2-pbr"
- "python2-requests"
- "python2-plumbum")
- cd "$_name-$pkgver"
- python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" ../LICENSE
-}