summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordianlujitao2021-09-05 18:35:25 +0800
committerdianlujitao2021-09-05 18:35:25 +0800
commitb40878808d0223995bd744a6c62199dbe60a69d5 (patch)
tree8a6f8f0432d85d8700380241837637aa2e3950ba /PKGBUILD
parentf34b81cd5c888300a9e91a4c3c658bb9108a327b (diff)
downloadaur-b40878808d0223995bd744a6c62199dbe60a69d5.tar.gz
Bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d2a5b1fa887..d67dd8722ec3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
# Maintainer: dianlujitao <dianlujitao at gmail dot com>
pkgname=python-hdf5storage
-pkgver=0.1.16
-_commit=d6e44f83ce2e25f7a5026cdac59b2ac74d832936
-pkgrel=2
-pkgdesc="Python package to read and write a wide range of Python types to/from HDF5 formatted files."
+pkgver=0.1.18
+pkgrel=1
+pkgdesc="Read and write a wide range of Python types to/from HDF5 formatted files."
url="https://github.com/frejanordsiek/hdf5storage"
depends=('python' 'python-numpy' 'python-h5py')
makedepends=('python-setuptools')
license=('BSD')
arch=('any')
-source=("$pkgname-$_commit.tar.gz::https://github.com/frejanordsiek/hdf5storage/archive/$_commit.tar.gz")
-sha256sums=('c361f8c49af17a624bee017edf4b6ca9e6ac47703092c9356dbaf9647ccd99c7')
+source=("https://github.com/frejanordsiek/hdf5storage/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('ce24b6267d1f59964b116cfa604c3142a1c9d7ac3a4704bca84963d820265e58')
build() {
- cd hdf5storage-$_commit
+ cd hdf5storage-$pkgver
python setup.py build
}
package() {
- cd hdf5storage-$_commit
+ cd hdf5storage-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 COPYING.txt $pkgdir/usr/share/licenses/$pkgname/COPYING.txt
}