summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-01-21 14:55:54 +0800
committerUniversebenzene2022-01-21 14:55:54 +0800
commit77b0955790e1a983d85fbc6e675bb6823b9d6bfb (patch)
treef4a5be391cb8afb338a43bebfdf0357d62325d2a /PKGBUILD
parent29e0c42821d0ad4987183fe6eb4eac9de6e345a2 (diff)
downloadaur-77b0955790e1a983d85fbc6e675bb6823b9d6bfb.tar.gz
Update to version 1.15.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6a041dc5667..f596c75f7bcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.15.0
+pkgver=1.15.1
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.6' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.60' 'python-six')
-makedepends=('cython>=0.16' 'python-pytest-runner')
+depends=('python>=3.7' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.80')
+makedepends=('cython')
optdepends=('python-healpy-doc: Documentation for healpy')
-checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-pillow' 'python-requests')
+checkdepends=('python-pytest-cython' 'python-pytest-doctestplus' 'python-requests')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('f0fc4e0a818fae18d349b66b05c7b178')
+md5sums=('d677ca493bd7694850028ce559443e9e')
prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ sed -i 's/3.80.0/3.80/' setup.py
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}