summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2023-08-17 13:42:43 +0800
committerUniversebenzene2023-08-17 13:42:43 +0800
commite10ee78a40ab8873f23e7ac0c3ee5eefcdb97484 (patch)
treef3460a69b3d1d80ef216c3d41e9a9dcb9cf39f5e /PKGBUILD
parentf0db6bfa2d21de449648a33fff67089b0b6b4547 (diff)
downloadaur-e10ee78a40ab8873f23e7ac0c3ee5eefcdb97484.tar.gz
Update to version 1.16.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d81ebefa0519..b85a4ce5b766 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=python-healpy
_pyname=${pkgname#python-}
-pkgver=1.16.3
+pkgver=1.16.5
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.8' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.80')
-makedepends=('python-setuptools'
+depends=('python>=3.8' 'python-numpy>=1.13' 'python-scipy' 'python-matplotlib' 'python-astropy' 'cfitsio>=4.1.0' 'healpix>=3.82')
+makedepends=('python-setuptools-scm>=6.2'
'cython'
'python-wheel'
'python-build'
@@ -18,7 +18,7 @@ optdepends=('python-healpy-doc: Documentation for healpy')
checkdepends=('python-pytest-cython'
'python-pytest-doctestplus') # requests -> pooch -> scipy
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('11ac43c53f1f935004393bde55667f9e')
+md5sums=('8c6d4b9c9fd87489827e1c08b918d383')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -40,8 +40,8 @@ check() {
cd ${srcdir}/${_pyname}-${pkgver}
# skip tests that cost lots of time
- pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv --color=yes \
-# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/healpy/test/test_pixelweights.py::test_pixelweights_local_datapath || warning "Tests failed"
+ pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" \
+ --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/healpy/test/test_pixelweights.py::test_pixelweights_local_datapath || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package() {