summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-05-06 22:47:02 +0800
committerUniversebenzene2020-05-06 22:47:02 +0800
commite241ecde316ad1ce8fdca15564a9413afd0e8691 (patch)
tree9d175372877a256f3aef4ff131e8781e0f55941d /PKGBUILD
parent9192604882b2c5604ffac788b8f09730d09c40cf (diff)
downloadaur-e241ecde316ad1ce8fdca15564a9413afd0e8691.tar.gz
Update to version 1.13.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 23 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9597dcda098..d581a5e39598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,35 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-healpy
-pkgver=1.12.10
+_pyname=${pkgname#python-}
+pkgver=1.13.0
pkgrel=1
pkgdesc="Python package to manipulate healpix maps"
arch=('i686' 'x86_64')
url="http://healpy.readthedocs.io"
license=('GPL')
-depends=('python>=3.4' 'python-numpy>=1.5' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix')
-makedepends=('cython>=0.16')
+depends=('python>=3.4' 'python-numpy>=1.13' 'python-matplotlib' 'python-astropy' 'cfitsio' 'healpix>=3.60')
+makedepends=('cython>=0.16' 'python-pytest-runner' 'python-six')
optdepends=('python-healpy-doc: Documentation for healpy')
+checkdepends=('python-pytest-cython')
source=("https://files.pythonhosted.org/packages/source/h/healpy/healpy-${pkgver}.tar.gz")
-md5sums=('9293b2e0bbcfaae1eedf0fd21399ef95')
+md5sums=('f7b055f9ce11faa827890bbcfb0663ba')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ export _pyver=$(python -V | cut -c 8-10)
+}
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
+
+ PYTHONPATH="./build/lib.linux-${CARCH}-${_pyver}" pytest
+}
package() {
cd ${srcdir}/healpy-${pkgver}