summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2019-03-23 11:33:15 +0800
committerUniversebenzene2019-03-23 11:33:15 +0800
commit2dd1a6603951b1d83bfc8b7deec78c017dc41a5b (patch)
tree43da7424dd7771f8aa4f0f21a18b17486f72a229 /PKGBUILD
downloadaur-2dd1a6603951b1d83bfc8b7deec78c017dc41a5b.tar.gz
Initial import 1.12.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94778f2ea825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=healpy
+pkgname=python-${_pyname}-doc
+pkgver=1.12.9
+pkgrel=1
+pkgdesc="Documentation for Python iminuit module"
+arch=('i686' 'x86_64')
+url="http://healpy.readthedocs.io"
+license=('GPL')
+makedepends=("python-${_pyname}=${pkgver}" 'python-numpydoc')
+source=("https://github.com/healpy/healpy/archive/${pkgver}.tar.gz"
+ 'fix_underline_warning.patch')
+md5sums=('2966c57f48c637611fe407fafa66f3b8'
+ 'd1fd09c9686b5eebdfbf06cd902e8575')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ patch -Np1 -i "${srcdir}/fix_underline_warning.patch"
+}
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/doc
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/doc/.build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+}