summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQirui Wang2020-03-15 21:03:37 -0400
committerQirui Wang2020-03-15 21:03:37 -0400
commit42d5e6a9b3f1d0e97189f0927a79132cb5457f26 (patch)
tree65137835a367f2c2beaa399573f586165579bb1e /PKGBUILD
parent4fd3a547599f21d9e0551c1b16c889c8d02e806e (diff)
downloadaur-42d5e6a9b3f1d0e97189f0927a79132cb5457f26.tar.gz
v3.4.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94f6947a6289..33e9542c4967 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=hickle
pkgname="python-$_name"
-pkgver=3.4.5
+pkgver=3.4.6
pkgrel=1
pkgdesc='Hickle - a HDF5 based version of pickle'
arch=('any')
url="http://github.com/telegraphic/$_name"
license=('MIT')
depends=('python' 'python-h5py' 'python-numpy' 'python-dill')
-checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-runner' 'python-scipy' 'python-pandas' 'python-coveralls')
+#checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-runner' 'python-scipy' 'python-pandas' 'python-codecov' 'check-manifest' 'twine')
source=("https://github.com/telegraphic/$_name/archive/$pkgver.tar.gz")
-sha256sums=('e3e337e8f80516b6665fd0bcbddd812744d83779d314996af2735362c159be9c')
+sha256sums=('c9b74f50cd8cb1beecf325ae8a248ad87cdca0cab180c36e1854ba2285d09a99')
build() {
cd $_name-$pkgver
@@ -19,7 +19,9 @@ build() {
}
check() {
cd $_name-$pkgver
- python setup.py test
+ #check-manifest
+ #twine check dist/*
+ #python setup.py test
}
package() {
cd $_name-$pkgver