summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2023-12-29 20:20:58 +0800
committerlilac2023-12-29 20:20:58 +0800
commitf9ca0d3a13b4d1ffc1d0a2166b1d74745037137b (patch)
treeca950ccfa60ecd31251e0cda228037d3e9915cfa /PKGBUILD
parentc09bd6f497988ad31c048a4379d28a927fdcf393 (diff)
downloadaur-f9ca0d3a13b4d1ffc1d0a2166b1d74745037137b.tar.gz
[lilac] updated to 0.28.1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 22 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8306f07de3dc..53e00e058b6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=horovod
pkgname=python-horovod
pkgver=0.28.1
-pkgrel=1
+pkgrel=2
pkgdesc='Distributed training framework for TensorFlow, Keras, PyTorch, and Apache MXNet'
arch=('x86_64')
url='https://github.com/horovod/horovod'
@@ -38,34 +38,35 @@ optdepends=(
'python-pytorch-cuda: pytorch framework'
'python-tensorflow-cuda: tensorflow framework'
)
-source=("${_pkgname}-${pkgver}::git+https://github.com/horovod/horovod.git#tag=v${pkgver}")
-sha512sums=('SKIP')
+source=("${_pkgname}-${pkgver}::git+https://github.com/horovod/horovod.git#tag=v${pkgver}"
+ "0001.fix-building-with-torch-2.1.patch::https://github.com/horovod/horovod/pull/3998.patch"
+)
+sha512sums=('SKIP'
+ '32ec82943a5f96de21b11b2b994f30779d827d8a5dab380654169eebc954e0dc122333d610fc32607a8bf11dd425117d035ab1f1cb8c6a36717c3c0b89692431')
prepare() {
cd "${_pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/0001.fix-building-with-torch-2.1.patch"
git submodule update --init --recursive
-# modify these environment variable as you need, see also https://github.com/horovod/horovod/blob/master/docs/install.rst
- export HOROVOD_BUILD_CUDA_CC_LIST="60,61,62,70,72,75,80,86,89,90"
- export HOROVOD_CPU_OPERATIONS=GLOO
- export HOROVOD_CUDA_HOME=/opt/cuda
- export HOROVOD_GPU=CUDA
- export HOROVOD_GPU_OPERATIONS=NCCL
- export HOROVOD_NCCL_LINK=SHARED
- export HOROVOD_WITHOUT_MXNET=1
- export HOROVOD_WITH_GLOO=1
- export HOROVOD_WITH_MPI=1
- export HOROVOD_WITH_PYTORCH=1
- export HOROVOD_WITH_TENSORFLOW=1
- export CC=/opt/cuda/bin/gcc
- export CXX=/opt/cuda/bin/g++
- # fix https://github.com/horovod/horovod/issues/3923
- cd "third_party/gloo"
- git pull https://github.com/facebookincubator/gloo.git
}
build() {
cd "${_pkgname}-${pkgver}"
- python -m build --wheel --no-isolation -x
+ # modify these environment variable as you need, see also https://github.com/horovod/horovod/blob/master/docs/install.rst
+ HOROVOD_BUILD_CUDA_CC_LIST="60,61,62,70,72,75,80,86,89,90" \
+ HOROVOD_CPU_OPERATIONS=GLOO \
+ HOROVOD_CUDA_HOME=/opt/cuda \
+ HOROVOD_GPU=CUDA \
+ HOROVOD_GPU_OPERATIONS=NCCL \
+ HOROVOD_NCCL_LINK=SHARED \
+ HOROVOD_WITHOUT_MXNET=1 \
+ HOROVOD_WITH_GLOO=1 \
+ HOROVOD_WITH_MPI=1 \
+ HOROVOD_WITH_PYTORCH=1 \
+ HOROVOD_WITH_TENSORFLOW=1 \
+ CC=/opt/cuda/bin/gcc \
+ CXX=/opt/cuda/bin/g++ \
+ python -m build --wheel --no-isolation
}
package() {