summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2021-06-28 20:55:12 +1000
committerMatthew Gamble2021-06-28 20:55:12 +1000
commitbacce4728f8b5e2e47e13f8e26224fc9374759ef (patch)
treecc090dd90c5140099d4a87bf6b436b91a62c042e /PKGBUILD
parent18aef25f7fe441d30aa6f4eacf99b688e4ff7c49 (diff)
downloadaur-bacce4728f8b5e2e47e13f8e26224fc9374759ef.tar.gz
Update to latest release
Also clean up various things, and include documentation with package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 22 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7c58b9a27db..f488cc55771a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,34 @@
# Maintainer: Maikel Wever <maikelwever@gmail.com>
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
pkgname=python-humanfriendly
-pkgver=9.1
+pkgver=9.2
pkgrel=1
pkgdesc="Human friendly input/output in Python"
+arch=('any')
url="https://github.com/xolox/python-humanfriendly"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
-source=("https://github.com/xolox/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('752c33e1e1ee2d9ebfa972ffced6c2a7')
-arch=('any')
+makedepends=('python-setuptools' 'python-sphinx')
+source=("https://github.com/xolox/python-humanfriendly/archive/${pkgver}.tar.gz")
+sha256sums=('63b6ae2ca33e7e8f5c3ae80b2a86d4bdf4d80e113afe02f4f1bd38031144f649')
+
+build() {
+ cd "python-humanfriendly-${pkgver}"
+
+ python setup.py build
+
+ cd docs
+ sphinx-build -nb html -d build/doctrees . build/html
+}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- cp LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+ cd "python-humanfriendly-${pkgver}"
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-humanfriendly/LICENSE.txt"
+ install -Dm644 CHANGELOG.rst "${pkgdir}/usr/share/doc/python-humanfriendly/CHANGELOG.rst"
+ cp -r docs/build/html "${pkgdir}/usr/share/doc/python-humanfriendly/html"
}
# vim:set ts=2 sw=2 et: