summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2017-01-07 11:42:53 +1100
committerMatthew Gamble2017-01-07 11:42:53 +1100
commite9a40d86e745918d2180f556fd2fa9b6806f7255 (patch)
tree00381f16104352274e8442f430af69f91a7d15f4 /PKGBUILD
parent4ae59dd91fdd3ecd9640c82710323fd7b28430fb (diff)
downloadaur-e9a40d86e745918d2180f556fd2fa9b6806f7255.tar.gz
Big update for python3.6
- Bump pkgrel to force re-install for python3.6 - Add --optimize=1 flag to install command - Copy license file into /usr/share/licenses - Code style updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b864b66fc009..20741aa24f3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
pkgname=python-idiotscript
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="An easier, less powerful alternative to regular expressions"
-arch=('any')
-url='https://github.com/djmattyg007/IdiotScript'
-license=('UNLICENSE')
-depends=('python')
-makedepends=('python-setuptools')
+arch=("any")
+url="https://github.com/djmattyg007/IdiotScript"
+license=("Unlicense")
+depends=("python")
+makedepends=("python-setuptools")
source=("https://github.com/djmattyg007/IdiotScript/archive/$pkgver.zip")
sha256sums=("c92ebfab3e3259eecafa0e3109b72fe7e713ab1dbae098175e72a923d439ae76")
package() {
- cd "IdiotScript-$pkgver"
- python setup.py install --root="$pkgdir"
+ cd "IdiotScript-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-idiotscript/LICENSE.txt"
}