summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Jouve2020-04-21 04:52:06 -0400
committerJean Jouve2020-04-21 04:52:06 -0400
commite64c0112773780119f2aa43fdc16ea2382d059be (patch)
treeddc63505388cbe0c70f00d504efc15618a71b29c /PKGBUILD
downloadaur-python-igl-git.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6f0f8276a77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jean Jouve <jean.jouve at protonmail dot com>
+
+pkgname=python-igl-git
+pkgver=0.4.1.r54.ae3b42e
+pkgrel=1
+pkgdesc="Python bindings for libigl"
+arch=('x86_64')
+url="https://github.com/libigl/libigl-python-bindings"
+license=('GPL' 'MPL2')
+depends=('glibc' 'gcc-libs' 'python-numpy')
+makedepends=('git' 'python-setuptools' 'cmake>=3.2')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('python-igl::git+https://github.com/libigl/libigl-python-bindings.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ #Using --tags because the tages in the repository are not annotated
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ python setup.py build
+}
+
+check() {
+ cd "${pkgname%-git}"
+ python setup.py test
+}
+
+package() {
+ cd "${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}