summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornfnty2016-02-15 21:11:40 +0100
committernfnty2016-02-15 21:11:40 +0100
commit66b6751a2f301e67ab47cccca1e687b549c1b955 (patch)
treeac2db3db7509fb958c932bb4c6301751552e7afd /PKGBUILD
parent7ab6fdb1b074439bf31eb640a888442aac4535e5 (diff)
downloadaur-66b6751a2f301e67ab47cccca1e687b549c1b955.tar.gz
Refactor pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9500cae3e76..c1694a37b40a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,9 +18,10 @@ sha512sums=('SKIP')
pkgver() {
cd "${srcdir}/${srcname}"
- printf 'r%s.%s\n' \
- "$( git rev-list HEAD | wc --lines )" \
- "$( git describe --always | sed 's/-/./g' )"
+ printf 'r%s.%s.%s\n' \
+ "$( git rev-list --count 'HEAD' )" \
+ "$( git log --max-count='1' --pretty='format:%ct' )" \
+ "$( git rev-parse --short 'HEAD' )"
}
package() {