summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroysstu2019-03-01 18:24:34 +0100
committeroysstu2019-03-01 18:24:34 +0100
commit777a6a6fd180f7ecfb83f8cb730fd16938769bc1 (patch)
tree2fdf4af9cf96e9fa00020a43de3670da5b1fafec /PKGBUILD
downloadaur-777a6a6fd180f7ecfb83f8cb730fd16938769bc1.tar.gz
v0.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bca35a7b7374
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Oystein Sture <oysstu a.t gmail.com>
+# Contributor:
+
+pkgname=python-imageio-ffmpeg
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="FFMPEG wrapper for Python"
+arch=("any")
+license=("BSD")
+url="https://github.com/imageio/imageio-ffmpeg"
+depends=('python' 'ffmpeg')
+makedepends=('python-setuptools')
+source=("https://github.com/imageio/imageio-ffmpeg/archive/v${pkgver}.tar.gz")
+sha256sums=("9998124f3c78faebbe98327fc18c3069789d77f32dd42e4480f0b84e8809138e")
+
+build() {
+ cd "imageio-ffmpeg-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "imageio-ffmpeg-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-imageio-ffmpeg/LICENSE"
+}