summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroysstu2021-02-13 10:02:00 +0100
committeroysstu2021-02-13 10:02:00 +0100
commitac80541e1d8c411e4100cea0bd32db6e6e016b0d (patch)
treee00f66f06d071852f4fa41df8f6c2cfb9ea56cb7 /PKGBUILD
parent703beb51e6c8bc8d1ed8dc5a4882c20f7a1c4abb (diff)
downloadaur-ac80541e1d8c411e4100cea0bd32db6e6e016b0d.tar.gz
Apply patch to remove pip requirement in setup.py
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da7c6efc08d7..1e48a3f4fce9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,22 @@
pkgname=python-imageio-ffmpeg
pkgver=0.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="FFMPEG wrapper for Python"
arch=("any")
license=("BSD")
url="https://github.com/imageio/imageio-ffmpeg"
depends=('python' 'ffmpeg')
makedepends=('python-setuptools')
-source=("https://github.com/imageio/imageio-ffmpeg/archive/v${pkgver}.tar.gz")
-sha256sums=('906680ae784d79972671c6a0adf5ce1604703506def9096d346f758a6a52bf6f')
+source=("https://github.com/imageio/imageio-ffmpeg/archive/v${pkgver}.tar.gz"
+ "pip_requirement.patch")
+sha256sums=('906680ae784d79972671c6a0adf5ce1604703506def9096d346f758a6a52bf6f'
+ '596d2c8a2cdbe157fd9da8f440075c8827c68f3595ac6106af74d802730b83d1')
+
+prepare() {
+ cd "imageio-ffmpeg-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/pip_requirement.patch"
+}
build() {
cd "imageio-ffmpeg-${pkgver}"