summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-12-21 10:47:31 +0800
committerUniversebenzene2020-12-21 10:47:31 +0800
commitc431ccc67379667d7d6599ba5f480d991c7bf6e5 (patch)
tree6d4c93b27ed58ce0818da90be21f3583d2216473 /PKGBUILD
parent51de70fd3a9b685bfdaabe90064374f135d8afab (diff)
downloadaur-c431ccc67379667d7d6599ba5f480d991c7bf6e5.tar.gz
Update to version 2.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3761c2a82afe..7bc1f4d9781f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,20 @@
pkgbase=python-iminuit
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc="Python interface for MINUIT, a physics analysis tool for function minimization."
arch=('i686' 'x86_64')
url="http://iminuit.readthedocs.io"
license=('GPL' 'MIT')
makedepends=('python-setuptools' 'python-numpy' 'cmake')
-#checkdepends=('python-pytest')
+checkdepends=('python-pytest'
+ 'python-scipy'
+# 'python-numba'
+ 'python-matplotlib')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('247246f939db7cc532454e3bd909daf6')
+md5sums=('d2f087cc90f9810791e8efbd5867bbe3')
prepare() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
@@ -24,10 +27,12 @@ build() {
python setup.py build
}
-#check() {
+check() {
# cd ${srcdir}/${_pyname}-${pkgver}/build/lib.linux-${CARCH}-${_pyver}
-# pytest || warning "Tests failed"
-#}
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ PYTHONPATH="build/lib.linux-${CARCH}-${_pyver}" pytest || warning "Tests failed"
+}
package_python-iminuit() {
depends=('python>=3.6' 'python-numpy')