summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Hafner2020-02-03 17:00:03 +0100
committerFabian Hafner2020-02-03 17:00:03 +0100
commitde72c4b9a05c2317975e50f5fb0efdf79b4d549c (patch)
treeac0b65062d775d1de143127acd99c9ae13a59d65 /PKGBUILD
downloadaur-de72c4b9a05c2317975e50f5fb0efdf79b4d549c.tar.gz
Impacket Python 3 GIT Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..742f51eeb70b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: coldbug <coldBug@e.mail.de>
+_pkgbase=impacket
+pkgname=python-impacket-git
+pkgver=impacket_0_9_20.r90.g13cfc72a
+pkgrel=1
+pkgdesc="Collection of classes for working with network protocols"
+arch=('any')
+conflicts=('impacket')
+url="https://github.com/SecureAuthCorp/impacket"
+license=("Apache")
+provides=('impacket')
+depends=('python' 'python-future' 'python-six' 'python-pyasn1' 'python-pycryptodome' 'python-pycryptodomex' 'python-pyopenssl' 'python-ldap3' 'python-flask' 'python-pcapy')
+makedepends=('git')
+source=("git+https://github.com/SecureAuthCorp/impacket.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgbase}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}