summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2019-08-31 19:32:22 -0400
committerredfish2019-08-31 19:32:22 -0400
commitc2aa38a82967d0fb19919590e9eefe84c57b6842 (patch)
treedf5988b8a27a0b36a8e1152fd8c048fa0b4fdcb5 /PKGBUILD
downloadaur-c2aa38a82967d0fb19919590e9eefe84c57b6842.tar.gz
0.4.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fed79831340a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=python-ipfshttpclient
+_name=ipfshttpclient
+pkgver=0.4.12
+pkgrel=1
+pkgdesc="Python IPFS HTTP client library"
+arch=('any')
+conflicts=("python-ipfsapi") # legacy name
+url="https://pypi.python.org/pypi/ipfshttpclient"
+license=('MIT')
+depends=('python'
+ 'python-multiaddr'
+ 'python-netaddr'
+ 'python-requests'
+ 'python-setuptools'
+ )
+checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-ordering' 'python-pytest-mock'
+ 'python-pytest-localserver' 'python-pluggy' 'python-py')
+optdepends=('go-ipfs: IPFS daemon') # an IPFS deamon is a checkdepend, but not required to be go-ipfs
+source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$_name-$pkgver"
+
+ # To exclude tests pass: -k 'not test_name'
+ ./test/run-tests.py
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+sha256sums=('0a199a1005fe44bff9da28b5af4785b0b09ca700baac9d1e26718fe23fe89bb7')