summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmaury Bodet2023-05-15 23:00:43 +0200
committerAmaury Bodet2023-05-15 23:00:43 +0200
commit98f448f8d7d9ef7f8842e6b24d545c8eb2e99c62 (patch)
tree250e7432910061238964a9b9664b76460884e477 /PKGBUILD
downloadaur-98f448f8d7d9ef7f8842e6b24d545c8eb2e99c62.tar.gz
Initial commit with v0.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8c8124a42f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: amo <https://aur.archlinux.org/account/amo>
+
+_pkgname=ipware
+pkgname=python-ipware
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Returns the best matched IP address from a given HTTP(s) header in Python"
+arch=('any')
+url="https://github.com/un33k/python-ipware"
+license=('MIT')
+makedepends=('python-setuptools')
+conflicts=('python-django-ipware')
+source=("$pkgname-$pkgver.src.tar.gz::https://github.com/un33k/python-ipware/archive/v$pkgver.tar.gz")
+sha256sums=('527c2b813688628d0dde2e35eddaf02994fc879dde9b38e76662ca16ebe6413e')
+
+build() {
+ cd "$pkgname-$pkgver" || exit
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver" || exit
+
+ export PYTHONHASHSEED=0
+ python setup.py install --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root="$pkgdir"
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}