summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2020-01-17 22:27:10 +0100
committerNarrat2020-01-17 22:27:10 +0100
commit57a105a42063638177b98cdc97a3668f2021dee7 (patch)
tree4fc19f3edb4601fca39346d5303791b5cc87d77f /PKGBUILD
parente9e67cc9aaf70be0f83062cce245c157e4f5639d (diff)
downloadaur-57a105a42063638177b98cdc97a3668f2021dee7.tar.gz
update to 0.3.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 28 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c84f13bf6728..95ab8d824830 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,43 @@
-# Maintainer: Jonathan Kotta <jpkotta at gmail dot com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Jonathan Kotta <jpkotta at gmail dot com>
+_name=ipython-sql
pkgbase=python-ipython-sql
pkgname=(python-ipython-sql python2-ipython-sql)
-pkgver=0.3.4
+pkgver=0.3.9
pkgrel=1
pkgdesc="Issue SQL commands from IPython."
arch=('any')
url="https://pypi.python.org/pypi/ipython-sql"
license=('custom:PYTHON')
-depends=('ipython' 'python-sqlalchemy' 'python-prettytable' 'python-sqlparse')
-source=(https://pypi.python.org/packages/source/i/ipython-sql/ipython-sql-$pkgver.tar.gz)
-md5sums=('a68076f11ae62197a16ed4000dcbe8d3')
-
-_package() {
- _python=$1
- cd $srcdir/ipython-sql-$pkgver
- $_python setup.py install --root="$pkgdir"
+makedepends=('ipython' 'python-sqlalchemy' 'python-prettytable' 'python-sqlparse')
+makedepends+=('ipython2' 'python2-sqlalchemy' 'python2-prettytable' 'python2-sqlparse')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+md5sums=('69407492ac7fcb92520e10d24b3b3194')
+
+
+prepare() {
+ cp -a ${_name}-${pkgver}{,-python2}
+}
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/${_name}-${pkgver}-python2"
+ python2 setup.py build
}
package_python-ipython-sql() {
- _package python
+ depends=('ipython' 'python-sqlalchemy' 'python-prettytable' 'python-sqlparse')
+
+ cd "${_name}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}
package_python2-ipython-sql() {
- depends=($(echo ${depends[*]} | sed s/python/python2/g))
- _package python2
+ depends=('ipython2' 'python2-sqlalchemy' 'python2-prettytable' 'python2-sqlparse')
+
+ cd "${_name}-${pkgver}-python2"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}