summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bershatsky2024-05-08 14:10:30 +0300
committerDaniel Bershatsky2024-05-08 14:10:30 +0300
commiteffd1658152ef9eb635951039f4ecc91d980dc0b (patch)
tree638c809341275e080536f1f7959c54cab1b0d6ac /PKGBUILD
parented7c7fa18b7808a904b5a2efb0decf55b02ac9e0 (diff)
downloadaur-effd1658152ef9eb635951039f4ecc91d980dc0b.tar.gz
Bump version to 0.4.27
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0b080a45119..896736372344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname='python-jax'
-pkgver=0.4.26
+pkgver=0.4.27
pkgrel=1
pkgdesc='Composable transformations of Python+NumPy programs'
arch=('any')
@@ -14,10 +14,13 @@ depends=('python-absl'
'python-numpy'
'python-opt_einsum'
'python-scipy')
-optdepends=('python-protobuf: Australis')
+optdepends=(
+ 'python-protobuf: Australis'
+ 'python-requests: Distributed computations'
+)
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("jax-${pkgver}.tar.gz::https://github.com/google/jax/archive/refs/tags/jax-v${pkgver}.tar.gz")
-sha256sums=('2bb12d1e42e41fbf5f2efb5eac41f275887aea8b4b14e36f16e7ca7a702f0e60')
+sha256sums=('8ed3d41704578a3db90ec3d0836d6f6f66355abe18b82dcdf6c4915bd9b6431a')
build() {
JAX_RELEASE=$pkgver python -m build -nw jax-jax-v$pkgver