summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Hirzel2023-08-16 17:13:52 -0400
committerAlex Hirzel2023-08-16 17:13:52 -0400
commit96a4a2af82106f8a3228ae76ff530fd1611b1668 (patch)
tree08c125c451d8b00a7f97ff369a81136843ec5932 /PKGBUILD
parent584617d734537caaf1f5736442f884118ecc68e1 (diff)
downloadaur-96a4a2af82106f8a3228ae76ff530fd1611b1668.tar.gz
update to version 4.23.1, fix dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79a54caf5b75..a52c0676f92b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,31 @@
pkgname=python-jsonargparse
_name=${pkgname#python-}
-pkgver=4.23.0
+pkgver=4.23.1
pkgrel=1
pkgdesc='Parsing library for CLI options, configs, and environment variables'
arch=('any')
url='https://github.com/omni-us/jsonargparse'
license=('MIT')
-depends=('python-yaml')
-makedepends=('python-argcomplete' 'python-attrs' 'python-fsspec' 'python-jsonschema' 'python-pydantic' 'python-pytorch' 'python-requests' 'python-responses')
-checkdepends=('python-coverage' 'python-pytest')
+depends=(
+ 'python'
+ 'python-argcomplete'
+ 'python-attrs'
+ 'python-docstring-parser'
+ 'python-fsspec'
+ 'python-jsonschema'
+ 'python-pydantic'
+ 'python-pytest'
+ 'python-pytorch'
+ 'python-requests'
+ 'python-responses'
+ 'python-yaml'
+ )
+checkdepends=(
+ 'python-coverage'
+ )
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('641d5e4545cd34720ed78f478ea19516d9831b03a59f672665cad228ead51997')
-
-#prepare() {
-# cd "$_name-$pkgver"
-# sed -i '2c\packages = jsonargparse' setup.cfg
-#}
+sha256sums=('f3bb4f52502193d395b9dc3ae20cf9b375226438b9140b6a8ad4ee3804441150')
build() {
cd "${srcdir}/${_name}-${pkgver}"