summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJagannathan Tiruvallur Eachambadi2020-04-26 11:31:58 +0200
committerJagannathan Tiruvallur Eachambadi2020-04-26 11:31:58 +0200
commit863d37b944e3ef3924e6082099ee5087f9a4340f (patch)
tree61c15c1919b2e3434483dba3467e085035700cc3 /PKGBUILD
parentbeb97be8f5c0eb7a5b4a7f30765ecf1fb7550af1 (diff)
downloadaur-863d37b944e3ef3924e6082099ee5087f9a4340f.tar.gz
updpkg 0.5.3 and run tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47363dcf72e5..1e918610dc8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,28 @@
_name="julia"
pkgname="python-${_name}"
-pkgver=0.5.1
+pkgver=0.5.3
pkgrel=1
pkgdesc="python interface to julia"
arch=('any')
url="https://github.com/JuliaPy/pyjulia"
license=('MIT')
depends=('python')
+checkdepends=(python-tox)
makedepends=('python-pypandoc' 'pandoc')
source=("$pkgname-$pkgver.tar.gz::https://github.com/JuliaPy/pyjulia/archive/v$pkgver.tar.gz")
-sha256sums=('cab4bba53c035402a1294915eff4b8b8dc7dd69b0bd9d931c1c4ed9a9dcc1fb8')
+sha256sums=('a02e55501fd7bc7583eb7f5b5efaf045fcb52e418ee9d5149be15c69505dbda8')
build() {
cd "pyjulia-$pkgver"
python setup.py build
}
+check() {
+ cd "pyjulia-$pkgver"
+ tox
+}
+
package() {
cd "pyjulia-$pkgver"
python setup.py install --root="$pkgdir" --prefix=/usr -O1 --skip-build