summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Manna2016-01-11 08:10:45 -0800
committerKyle Manna2016-01-11 08:10:45 -0800
commit1e29f65a5b59759c598ea2df2e5fefed735cff62 (patch)
treefefa771a3a1bb5cc596cb0ef4f724c197484202d /PKGBUILD
downloadaur-1e29f65a5b59759c598ea2df2e5fefed735cff62.tar.gz
release: v0.5-1
* Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71830c08bce2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
+pkgname=python-kademlia
+_pkgname=${pkgname/python-/}
+pkgver=0.5
+pkgrel=1
+pkgdesc="Distributed hash table for decentralized peer-to-peer computer networks"
+url="http://github.com/bmuller/kademlia"
+depends=('python' 'python-twisted')
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/k/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('5069c5d404226165ed30b9384be5dedf5f16b065ddf2344c66aa3222583e1d94')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ rm -rf ${pkgdir}/usr/lib/python*/site-packages/tests/
+}
+