summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Manna2016-01-11 08:10:45 -0800
committerKyle Manna2016-01-11 08:28:22 -0800
commitfce98a748a9fa6b47021ca0d2ff417e55d8f1240 (patch)
tree177e881a7fe28b7df51321d48d56e9d0eed3002a /PKGBUILD
parent8001b0c44dea4adaff039c39f97a70aaf0b3699c (diff)
downloadaur-fce98a748a9fa6b47021ca0d2ff417e55d8f1240.tar.gz
release: v0.5-3 start fixing Python 3 issues
* Start at fixing the thigns that changed with Python 3. * Not sure that this works.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ff637d7ac13..ab8f4eabfcd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-kademlia
_pkgname=${pkgname/python-/}
pkgver=0.5
-pkgrel=2
+pkgrel=3
pkgdesc="Distributed hash table for decentralized peer-to-peer computer networks"
url="http://github.com/bmuller/kademlia"
depends=('python' 'python-twisted' 'python-rpcudp')
@@ -14,6 +14,8 @@ sha256sums=('5069c5d404226165ed30b9384be5dedf5f16b065ddf2344c66aa3222583e1d94')
build() {
cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 < "$srcdir/../0001-storage-Python-3-fix-for-izip.patch"
+ patch -p1 < "$srcdir/../0002-storage-Python-3-fix-for-imap.patch"
python setup.py build
}