summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLumaku2020-11-29 16:54:44 +0100
committerLumaku2020-11-29 16:54:44 +0100
commit00a25930c35e5a45412de02c6b5ad1b15b537d4c (patch)
tree2a10379c7283d860d97d2474b1374080c40b985b /PKGBUILD
downloadaur-00a25930c35e5a45412de02c6b5ad1b15b537d4c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89669eba4c6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Lumaku <lumaku@mailbox.org>
+pkgname=python-kaldiio-git
+pkgver=2.17.0.r252
+pkgrel=1
+pkgdesc='Pure Python module for reading and writing kaldi ark files'
+arch=('any')
+url='https://github.com/nttcslab-sp/kaldiio'
+license=('custom:NTT')
+depends=('python>=3.7' 'python-pytorch-complex-git' 'python-numpy')
+makedepends=('git')
+provides=('python-kaldiio')
+conflicts=("python-kaldiio-git" "${pkgname}")
+source=(
+ "${pkgname}::git+${url}")
+md5sums=(
+ 'SKIP')
+
+
+pkgver() {
+ cd "${pkgname}"
+ printf "%s.r%s" "$(python setup.py --version)" "$(git rev-list --count HEAD)"
+}
+
+
+build() {
+ cd "${pkgname}"
+ python setup.py build
+}
+
+
+package() {
+ cd "${pkgname}"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+