summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorotaj2023-11-06 13:26:27 +0100
committerotaj2023-11-06 13:26:27 +0100
commitaa60e8075b18015942ce68e41d0f7626d6b81a3b (patch)
tree53f370394a3d6d46404bdd969dbaa6a41503f480 /PKGBUILD
parent555dd185baac7522314037398d4cb75cc08023a8 (diff)
downloadaur-python-kornia.tar.gz
verbump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 404430ab53fa..72a0dbee1746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: otaj
-# If you also want to test GPU portion of the package, set this to 1. Make sure you have a capable GPU with large enough memory
+# If you also want to test GPU portion of the package, set this to 1. Make sure you have a capable GPU with large enough memory
TEST_GPU=0
pkgname=python-kornia
_name=kornia
-pkgver=0.6.12
+pkgver=0.7.0
pkgrel=1
arch=(any)
url='https://github.com/kornia/kornia'
@@ -17,23 +17,23 @@ checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-mypy' 'python-p
options=(!emptydirs)
# because kornia does not ship `pytest.ini` with their release, we have to get a fat copy of full repo
source=("${_name}-${pkgver}.zip::${url}/archive/refs/tags/v${pkgver}.zip")
-sha256sums=('a9921e3408813691543ed61c372825d4c7f6823ca7e6f4088c1d71fd5f55e420')
+sha256sums=('a0497c29f2612de9b4fe4266ef6a65c98c45ba04c6c90671bb58a1f0d39d5028')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
- python -m build --wheel --no-isolation
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
}
check() {
- cd "${srcdir}/${_name}-${pkgver}"
- pytest -v --device cpu --dtype float32,float64 --cov=kornia test/
- if ! [ "$TEST_GPU" -eq "0" ] ; then
- pytest -v --device cuda --dtype all --cov=kornia test/
- fi
+ cd "${srcdir}/${_name}-${pkgver}"
+ pytest -v --device cpu --dtype float32,float64 --cov=kornia test/
+ if ! [ "$TEST_GPU" -eq "0" ]; then
+ pytest -v --device cuda --dtype all --cov=kornia test/
+ fi
}
package() {
- cd "${srcdir}/${_name}-${pkgver}"
- python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}