summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtakar Jašek2020-06-26 19:11:58 +0200
committerOtakar Jašek2020-06-26 19:11:58 +0200
commit4af188d305b40a627271de9ca5fb35098b0ac21f (patch)
tree9b6ee7fd7e4cbd0feda10c018e7237e166b51245 /PKGBUILD
parent658e313e7776543f6a1ed45a490b7592cb7d5c1a (diff)
downloadaur-4af188d305b40a627271de9ca5fb35098b0ac21f.tar.gz
pkgver bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2b8828e17a1..5c70b406d477 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
pkgname=python-kornia
_name=kornia
-pkgver=0.2.1
+pkgver=0.3.1
pkgrel=1
arch=(any)
url='https://github.com/kornia/kornia'
pkgdesc='Open Source Differentiable Computer Vision Library for PyTorch'
license=(Apache)
makedepends=('python-setuptools')
-depends=('python-pytorch' 'python-torchvision' 'opencv' 'python-matplotlib' 'ipython' 'jupyter')
-checkdepends=('python-pytest')
+depends=('python-pytorch' 'python-torchvision' 'python-numpy')
+checkdepends=('python-pytest' 'python-pytest-runner')
options=(!emptydirs)
source=(${_name}-${pkgver}.tar.gz::"${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('95eb4c5f84325e4fff887ef1a8a9f8aeb634bd014031e0c3c08bcd18a5d3cd24')
+sha256sums=('b9d45114e14f23cbe24d965f3095e0159b06d5672787959b81d6f9b4242e6c5d')
check() {
cd "${srcdir}/${_name}-${pkgver}"
- pytest
+ pytest -v --device all --dtype all test/
}
package() {