summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoerg Behrmann2017-01-26 15:25:30 +0100
committerJoerg Behrmann2017-01-26 15:27:08 +0100
commit1d230946066afb3f77a0941e8046c70e1c89fefe (patch)
tree516c8fa23ba05b0a74088738323229944964c112 /PKGBUILD
parent077285d5a32ede4af860e6d1d0bda8cdec41598b (diff)
downloadaur-1d230946066afb3f77a0941e8046c70e1c89fefe.tar.gz
Add note on how to build with MUMPS-support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91d970a334bc..4d4bb5655cce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Max Schlemmer <max.schlemmer@gmail.com>
pkgname=python-kwant
pkgver=1.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Python package for numerical calculations on tight-binding models with a strong focus on quantum transport"
arch=('any')
url="http://kwant-project.org/"
@@ -10,7 +10,7 @@ license=('BSD')
depends=(python python-scipy lapack blas python-tinyarray)
optdepends=(
'python-matplotlib: needed for plotting support and the tutorial'
- 'mumps: a sparse linear algebra library for speed up and memory usage reduction'
+ 'mumps: a sparse linear algebra library for speed up and memory usage reduction (use AUR mumps-seq-shared or any other built as shared library)'
)
checkdepends=(python-nose)
source=(
@@ -21,6 +21,14 @@ sha1sums=('7a2aa07492c3aee8930fd7de402e62fea84f3eca'
'SKIP')
validpgpkeys=('52299057FAD799653C4F088AC3F147F5980F3535')
+# Comment the prepare function if you want to build _without_ mumps support.
+# This is discouraged because without the incurred performance penalty no
+# serious calculations can be done in a reasonable time.
+prepare() {
+ cp "../build.conf" "$srcdir/kwant-$pkgver/build.conf"
+ cp "../setup.py" "$srcdir/kwant-$pkgver/setup.py"
+}
+
build() {
cd "$srcdir/kwant-$pkgver"
python setup.py build