summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoerg Behrmann2017-03-27 13:52:41 +0200
committerJoerg Behrmann2017-03-27 13:52:41 +0200
commite06eb2c057923768409b9b4a7a6b9f7fa0a6c4ee (patch)
tree1d29a0ce0b00f2cfe740f3bc632fa3fd17d09513 /PKGBUILD
parent2ecde885bc88927bd951b746a1c5f216eac07035 (diff)
downloadaur-e06eb2c057923768409b9b4a7a6b9f7fa0a6c4ee.tar.gz
Add missing pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99547d100f07..49b407cdd097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,11 @@ sha256sums=('SKIP'
'32bef0aa0a6f329102c5244d856d4b50796c601b1d25e7c708e0e9bdf54425c7')
validpgpkeys=('52299057FAD799653C4F088AC3F147F5980F3535')
+pkgver() {
+ cd "kwant"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
# Comment the prepare function if you want to build _without_ mumps support.
# This is discouraged because without the incurred performance penalty no
# serious calculations can be done in a reasonable time.