summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-01-09 12:31:21 -0600
committerLuis Martinez2022-01-09 12:31:21 -0600
commit4ca08e8ece92eea7e024bb7c6f7674498419064b (patch)
treeb7afb7842603afac53b8dc2ec1773595c095893e /PKGBUILD
parent083f4d50e9bb0fc08afb3e969b3ae5d06a9d2189 (diff)
downloadaur-4ca08e8ece92eea7e024bb7c6f7674498419064b.tar.gz
update to 2.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df3d1a6f1a1d..6d70cfc07d03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,38 @@
pkgname=python-laspy
pkgdesc="Pythonic interface for .LAS LIDAR files"
url="https://github.com/laspy/laspy"
-pkgver=2.0.3
-_commit=4438f472de74e44df45309c84feb517f7538ed09
+pkgver=2.1.0
+_commit=af790d5
pkgrel=1
arch=('any')
license=('custom')
depends=('python-numpy')
-makedepends=('git' 'python-setuptools' 'python-sphinx' 'python-sphinx_rtd_theme')
-source=("$pkgname-$pkgver::git+$url#commit=$_commit?signed")
+makedepends=(
+ 'git'
+ 'python-m2r2'
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-sphinx_rtd_theme')
+changelog=CHANGELOG.md
+source=("$pkgname::git+$url#commit=$_commit?signed")
sha256sums=('SKIP')
validpgpkeys=('44B238524D21C5064D7081BD5022EF94BE848C51')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
python setup.py build
cd docs
PYTHONPATH=../ make man
}
package() {
- cd "$pkgname-$pkgver"
+ export PYTHONHASHSEED=0
+ cd "$pkgname"
python setup.py install \
--prefix=/usr \
--root="$pkgdir" \
--optimize=1 \
--skip-build
- install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm 644 docs/_build/man/laspy.1 -t "$pkgdir/usr/share/man/man1/"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 docs/_build/man/laspy.1 -t "$pkgdir/usr/share/man/man1/"
}