summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyechou2020-05-08 07:15:04 -0500
committerkyechou2020-05-08 07:15:04 -0500
commit518384a6060e002e87fa75d96c17ca31dc35d526 (patch)
treeb69212817f497ffcbed56b8d55f1193827c30f50 /PKGBUILD
downloadaur-518384a6060e002e87fa75d96c17ca31dc35d526.tar.gz
Release 1.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f830c4b442ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
+
+pkgname=python-laspy
+pkgdesc="A pythonic interface for .LAS LIDAR files matching specification 1.0-1.4"
+url="https://github.com/laspy/laspy"
+pkgver=1.7.0
+pkgrel=1
+arch=('any')
+depends=('python')
+makedepends=('git' 'python-setuptools') # 'python-six')
+license=('custom')
+source=("https://github.com/laspy/laspy/archive/${pkgver}.tar.gz")
+sha512sums=('8331ef5eccda67f29b5c013974390ce1ccebf44f7bda3f3683a97c4a0340b7b2ec0d9c205c6077a7bb40ebb2576a49b97b2a7c46f2f0c384b6ada4386f6c6c0b')
+
+build() {
+ cd "$srcdir/laspy-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/laspy-${pkgver}"
+ python setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir" \
+ --optimize=1 \
+ --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}