summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergio2021-03-25 13:45:46 +0000
committerSergio2021-03-25 13:45:46 +0000
commitfd3e8bcdbe11dcaab18279f8bc048e84ead1dde8 (patch)
tree131dd2b1cd7c78a2f50e2ef96ec22455983c57d0 /PKGBUILD
parentbc74648ae5124378df655ff11f07f4e4204c9c7a (diff)
downloadaur-fd3e8bcdbe11dcaab18279f8bc048e84ead1dde8.tar.gz
updating to version 0.3.4 and dropping support for python 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b11248efe553..56dfc0e06d0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: mcgyver <newsletter.sergio@gmail.com>
pkgbase=python-lazyarray
-pkgname=('python-lazyarray' 'python2-lazyarray')
+#pkgname=('python-lazyarray' 'python2-lazyarray')
+pkgname=('python-lazyarray')
_name=${pkgbase#python-}
-pkgver=0.3.3
+pkgver=0.3.4
pkgrel=1
pkgdesc="a Python package that provides a lazily-evaluated numerical array class, larray, based on and compatible with NumPy arrays"
arch=('any')
url="https://pypi.org/project/lazyarray/#files"
license=('BSD')
-makedepends=("python" "python2" 'python-setuptools')
+#makedepends=("python" "python2" 'python-setuptools')
+makedepends=("python" 'python-setuptools')
+conflicts=("python2-lazyarray")
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('SKIP')
+sha256sums=('357e80db7472c940ed3cab873544f2b7028f6ade8737adde2c91f91aeab2835a')
package_python-lazyarray() {
depends+=('python')
@@ -20,10 +23,10 @@ package_python-lazyarray() {
python setup.py install --root="${pkgdir}"
}
-package_python2-lazyarray() {
- depends+=('python2')
-
- cd "${srcdir}/${_name}-${pkgver}"
- python2 setup.py install --root="${pkgdir}"
-}
+#package_python2-lazyarray() {
+# depends+=('python2')
+#
+# cd "${srcdir}/${_name}-${pkgver}"
+# python2 setup.py install --root="${pkgdir}"
+#}