summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 19:04:09 -0700
committerGI_Jack2023-05-13 19:04:09 -0700
commit1d374c68e4bd3048f4d87bb0f752114bad7dec46 (patch)
tree66946734af898868342b3578d4b34234f250529a /PKGBUILD
parentc08018dfce845b3cb96825a2f05749e88688fd31 (diff)
downloadaur-python-ldapdomaindump.tar.gz
version 0.9.4
Also updated for modern build standards
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1619200fb2c3..597c6aaa4734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,23 @@
pkgname=python-ldapdomaindump
_pypiname=ldapdomaindump
-pkgver=0.9.3
+pkgver=0.9.4
pkgrel=1
pkgdesc="Active Directory information dumper via LDAP, written in python"
url="https://github.com/dirkjanm/ldapdomaindump/"
arch=('any')
license=('MIT')
depends=('python' 'python-future' 'python-dnspython' 'python-ldap3')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=(${_pypiname}-${pkgver}.tar.gz::"https://github.com/dirkjanm/ldapdomaindump/archive/v${pkgver}.tar.gz")
-sha256sums=('30d269f8c638a1446d7a71d01c41e2a03ea0b9742ada471414db91bd77927f40')
+sha256sums=('43a0822c96d06b8f7a3e3f044deb1591344c84d273c9d7f5815347c88af300fa')
+
+build() {
+ cd ${_pypiname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
package() {
- cd ${_pypiname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd ${_pypiname}-${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}