summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2021-03-27 10:23:47 -0400
committerGuillaume Horel2021-03-27 10:23:47 -0400
commit0f17569f879a8745990a92f77dbf6a946cf03718 (patch)
tree72c7d4e9508295d2e842f5035ef618ddc0bdb6b6 /PKGBUILD
parentd774f88ff8eb0db5d72b316c30e42c8303f59220 (diff)
downloadaur-0f17569f879a8745990a92f77dbf6a946cf03718.tar.gz
bump to 4.23
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80913b97f33a..5b2261ee06d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-linearmodels'
_module='linearmodels'
-pkgver='4.17'
+pkgver=4.23
pkgrel=1
pkgdesc="Linear models in Python."
url="https://bashtage.github.io/linearmodels/doc"
-depends=('python-numpy'
+depends=('python-pyhdfe'
+ 'python-numpy'
'python-pandas'
'python-patsy'
'python-scipy')
@@ -14,8 +15,15 @@ optdepends=('python-xarray')
makedepends=('cython' 'python-setuptools')
license=('custom:University of Illinois/NCSA Open Source License')
arch=('x86_64')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/bashtage/linearmodels/archive/${pkgver}.tar.gz")
-sha256sums=('fbffd00535fa94691f7a8c985211726cc6b2cd3ed4fc7d1709ef4c9d1d7d6636')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bashtage/linearmodels/archive/refs/tags/v${pkgver}.tar.gz"
+ "https://patch-diff.githubusercontent.com/raw/bashtage/linearmodels/pull/336.patch")
+sha256sums=('74e7e131b22e8817efe35b04d3d4193262ed4c17e3d2aefafc4209c69288d823'
+ '3e3c40a8cf95e5ec22b46758f9799a010e88f7fc124e916fbce689afb6258acd')
+
+prepare() {
+ cd "${_module}-${pkgver}"
+ patch -p1 -i ../336.patch
+}
build() {
cd "${_module}-${pkgver}"
@@ -28,7 +36,7 @@ package() {
install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}
-#check() {
- #cd "${_module}-${pkgver}"
- #pytest linearmodels --skip-slow
-#}
+check() {
+ cd "${_module}-${pkgver}"
+ pytest linearmodels --skip-slow
+}