summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2024-04-29 15:56:15 -0400
committerGuillaume Horel2024-04-29 15:56:15 -0400
commit50489f375de5c9fb1454e81d1f9f540b854aa9f8 (patch)
tree063d1e7c63c90238656dbbe55e071955e666f3de /PKGBUILD
parent5c094f38adf54ccc369a35af612f08f2f478bf8e (diff)
downloadaur-50489f375de5c9fb1454e81d1f9f540b854aa9f8.tar.gz
bump to 6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd026c385f48..5a62997a698c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-linearmodels'
_module='linearmodels'
-pkgver='5.1'
+pkgver='6.0'
pkgrel=1
pkgdesc="Linear models in Python."
url="https://bashtage.github.io/linearmodels/doc"
depends=('python-formulaic'
'python-numpy'
'python-pandas'
- 'python-property-cached'
'python-pyhdfe'
'python-scipy'
'python-statsmodels')
@@ -18,11 +17,11 @@ makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'pyt
license=('custom:University of Illinois/NCSA Open Source License')
arch=('x86_64')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.tar.gz")
-sha256sums=('1a157a974a346a78b9a3e42b86e5a624b052c4269b0441f56deac57f75cf95c5')
+sha256sums=('3420108ba172bae6f433264fcda2c73ee1da750f7c7057722c370e41b0637ff1')
build() {
cd "${_module}-${pkgver}"
- python -m build --wheel --no-isolation
+ python -m build -x --wheel --no-isolation
}
package() {