summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Klimczak2018-09-30 17:40:46 +0200
committerMichael Klimczak2018-09-30 17:40:46 +0200
commit4f3c4c2033e8cfe3438bda18f01586ba983af918 (patch)
treec8fdca3065e08fa6145b5d1f62e9aa20045ab9a6 /PKGBUILD
parentabbabd4bb4fb7454d9d94e680da0144156ff0261 (diff)
downloadaur-4f3c4c2033e8cfe3438bda18f01586ba983af918.tar.gz
added patch and modified PKGBUILD to fix issues with python 3.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c830fb6ceeb..dfd0f56fb1c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
# Contributor: lestb <tkhdlstfl dot l plus aur at gmail dot com>
# Contributor: Sebastien Binet <binet@lblbox>
pkgname=python-lineprofiler
-pkgver=2.1
-pkgrel=2
+pkgver=2.1.2
+pkgrel=3
pkgdesc="Line-by-line profiler"
url="https://pypi.python.org/pypi/line_profiler"
arch=('i686' 'x86_64')
license=('BSD')
depends=('python-setuptools' 'ipython')
makedepends=('cython')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/rkern/line_profiler/archive/$pkgver.tar.gz")
-sha256sums=('5625157e76e1f70c237c7df07389b48028aa1b94ec630aaa5f094d5755bcaa76')
+source=(https://files.pythonhosted.org/packages/14/fc/ecf4e238bb601ff829068e5a72cd1bd67b0ee0ae379db172eb6a0779c6b6/line_profiler-${pkgver}.tar.gz line_profiler.patch)
+md5sums=('141cb6996f0e3188ca05bfddcb403e36' 'fd05a4246f3bb741bbf9b51ca3e14d34')
build() {
+ cd "${srcdir}"
+ patch -s -p0 < line_profiler.patch
+
cd "${srcdir}/line_profiler-${pkgver}"
+ cython _line_profiler.pyx
python setup.py build
}