summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuan Guo2016-02-10 16:59:38 +0100
committerQuan Guo2016-02-10 16:59:38 +0100
commit2667cbf9503f6c6b9c7eba0b33fd97ef357ec088 (patch)
tree830b9f581f0faf429d9baa704bb29f358145f832 /PKGBUILD
parentfe71a85384360b9bbe4e44d66e11f4ad8fd86c94 (diff)
downloadaur-2667cbf9503f6c6b9c7eba0b33fd97ef357ec088.tar.gz
Compile with llvm 3.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac4f6a0627dd..9fff8f1b36c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=(python-llvmlite-git python2-llvmlite-git)
pkgbase=python-llvmlite-git
_gitname=llvmlite
-pkgver=0.6.0.r10.g6cf9861
+pkgver=0.9.0.dev.r48.g775c5e0
pkgrel=1
pkgdesc="A lightweight LLVM python binding for writing JIT compilers"
url="https://github.com/numba/llvmlite"
@@ -32,6 +32,7 @@ package_python-llvmlite-git() {
provides=('python-llvmlite')
cd ${srcdir}/${_gitname}
+ sed -i 's/-lLLVMOProfileJIT/ /g' ffi/Makefile.linux
python setup.py install \
--prefix=/usr \
--root=$pkgdir
@@ -42,6 +43,7 @@ package_python2-llvmlite-git() {
provides=('python2-llvmlite')
cd ${srcdir}/${_gitname}-py2
+ sed -i 's/-lLLVMOProfileJIT/ /g' ffi/Makefile.linux
python2 setup.py install \
--prefix=/usr \
--root=$pkgdir