summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2018-03-18 16:51:58 +0000
committerGrey Christoforo2018-03-18 16:51:58 +0000
commit03fe283b98033f7454786127ceca19cea68a28c5 (patch)
treece25938564d3c6cf2d90705913eb8b4319c4a4bd /PKGBUILD
parent1ca5048eb293e04aecae276fcaf461b135ff5f40 (diff)
downloadaur-03fe283b98033f7454786127ceca19cea68a28c5.tar.gz
add python2-lmfit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbbb43152afb..47542299297c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
-pkgname=python-lmfit
+pkgbase=python-lmfit
+pkgname=('python-lmfit' 'python2-lmfit')
pkgver=0.9.8
pkgrel=1
pkgdesc="Least-Squares Minimization with Constraints for Python"
arch=('any')
url="http://lmfit.github.io/lmfit-py/"
license=('BSD')
-depends=('python' 'python-numpy' 'python-scipy')
-makedepends=('python-setuptools')
-checkdepends=('python-nose')
source=(https://github.com/lmfit/lmfit-py/archive/${pkgver}.tar.gz)
-
-build() {
- cd "$srcdir/lmfit-py-$pkgver"
- python setup.py build
-}
+md5sums=('56744e7bb1033a8ff0a69b6365c8b323')
#check() {
# cd "$srcdir/lmfit-py-$pkgver"
# nosetests3 tests
#}
-package(){
+package_python-lmfit(){
+ checkdepends=('python-nose')
+ depends=('python' 'python-numpy' 'python-scipy')
cd "$srcdir/lmfit-py-$pkgver"
python setup.py install --root="${pkgdir}" --optimize=1
}
+package_python2-lmfit(){
+ checkdepends=('python2-nose')
+ depends=('python2' 'python2-numpy' 'python2-scipy')
+ cd "$srcdir/lmfit-py-$pkgver"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}
+
# vim:ts=2:sw=2:et:
-md5sums=('56744e7bb1033a8ff0a69b6365c8b323')