summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStick2020-04-02 11:21:21 -0400
committerStick2020-04-02 11:21:21 -0400
commit7eb684ca57dfa11395ea72e287a4dc3e906969fe (patch)
treeed4b37893fa535cdbc6c93622219d63c63153155 /PKGBUILD
parent4cb189e835c62eef7845d3cac1f0ed3f3f600a3f (diff)
downloadaur-7eb684ca57dfa11395ea72e287a4dc3e906969fe.tar.gz
create setuptools package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 20 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a514aadfa9e..44f423ae465b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,36 @@
# Maintainer: Stick <stick@stma.is>
# Contributer: Sherlock Holo <Sherlockya@gmail.com>
-_pkg=locust
-pkgname="python-$_pkg-git"
-pkgver=0.14.5.r83.g34cb6d1
-pkgrel=2
+pkgname=python-locustio
+_name=${pkgname#python-}
+pkgver=0.14.5
+pkgrel=1
pkgdesc="Scalable user load testing tool written in Python"
arch=('any')
-url="https://github.com/locustio/$_pkg"
+url='https://locust.io/'
license=('MIT')
-depends=('python-configargparse'
- 'python-flask'
+depends=(
'python-gevent'
- 'python-geventhttpclient-wheels'
+ 'python-flask'
+ 'python-requests'
'python-msgpack'
- 'python-psutil'
'python-pyzmq'
- 'python-requests'
- 'python-six')
-makedepends=('git'
- 'python-setuptools')
-provides=("python-$_pkg")
-conflicts=("python-$_pkg")
-source=("$pkgname::git+$url")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$pkgname" || exit
- local _ver
- _ver="$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
- printf '%s\n' "${_ver#v}"
-}
+ 'python-geventhttpclient-wheels'
+ 'python-configargparse'
+ 'python-psutil'
+)
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('8ec934226e41ccfdf8d5609050cafcb6449ead09e8697104bfa86739a38dd036')
+provides=("$pkgname")
+conflicts=("$pkgname")
build() {
- cd "$pkgname" || exit
- sed -i 's/msgpack-python/msgpack/' setup.py
- sed -i 's/ "\([[:alpha:]-]*\).=.*"/ "\1"/' setup.py
+ cd "$srcdir"/locustio-$pkgver
python setup.py build
}
package() {
- cd "$pkgname" || exit
- python setup.py install --skip-build --root="$pkgdir"/ --optimize=1
+ cd "$srcdir"/locustio-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}