summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Ostuni2019-07-05 13:14:34 +0200
committerDario Ostuni2019-07-05 13:14:34 +0200
commit437556e41e165a531daa4f57faa5aa609904ee6a (patch)
tree2c8fb03a960120e010ab5b699ef59307d37b4f6d /PKGBUILD
downloadaur-437556e41e165a531daa4f57faa5aa609904ee6a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4722f1c2a279
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+pkgname=python-logicmin
+pkgver=0.3.18
+pkgrel=1
+pkgdesc="Logic Minimization in Python"
+arch=('any')
+url="https://github.com/dreylago/logicmin"
+license=('MIT')
+depends=('python' 'python-future')
+options=(!emptydirs)
+source=("https://github.com/dreylago/logicmin/archive/${pkgver}.tar.gz"
+ "001-fix-python2-print.diff")
+sha384sums=('5f183125c4ad8376d9b9040d225252cec2e37e438e56a96288b83b4f5f9dad0919bb50f5c571185da5a48fd5012badc9'
+ '7a33b00a26c1c165f04b40a61382a9e0a0abd6364ccaf9562ef199cda5c965cac99dc34e27e5ff2e4d0a26215c5634bd')
+
+prepare() {
+ cd "$srcdir/logicmin-${pkgver}"
+ patch -p1 < "${srcdir}/001-fix-python2-print.diff"
+}
+
+package() {
+ cd "$srcdir/logicmin-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}