summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-14 13:43:57 -0500
committerCarlos Aznarán Laos2022-01-14 13:43:57 -0500
commit74bfa7b906f903ef56f31754ab3751f018823eda (patch)
tree3264e917238793ea81c6f68877fe80db18f440c3 /PKGBUILD
parent7a6881c9787577d0681b8534ec2748a5bada3dd7 (diff)
downloadaur-python-ludwig.tar.gz
Drop python2-numba
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 40 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b14f7a357a8..2597263f875e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,50 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
-
-pkgname=python-ludwig
-pkgver=0.1.0
-pkgrel=5
-pkgdesc='Train and test deep learning models'
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+_base=ludwig
+pkgname=python-${_base}
+pkgver=0.4
+pkgrel=1
+pkgdesc="Data-centric declarative deep learning framework"
arch=(any)
-url='https://github.com/uber/ludwig'
+url="https://github.com/${_base}-ai/${_base}"
license=(MIT)
-depends=(cython python-cloudpickle python-dask python-h5py python-matplotlib python-numpy python-pandas python-scipy python-scikit-learn python-tqdm python-tabulate python-tensorflow python-yaml python-pytest python-scikit-image python-seaborn python-spacy-en_core_web_sm 'python-spacy>=2.0')
-depends+=(python2-numba) # python2-numba is requored for the check() function in python-sparse to pass
-makedepends=(git)
-optdepends=('ludwig-example: example use of Ludwig')
-source=("git+https://github.com/uber/ludwig#tag=v$pkgver")
-sha256sums=('SKIP')
+depends=(cython python-pandas python-tabulate python-scikit-learn python-yaml absl-py kaggle-api python-pytables python-fsspec python-dataclasses-json python-jsonschema) # python-tensorflow
+# python-cloudpickle python-pytest python-spacy-en_core_web_sm
+# checkdepends=(python-pytest-timeout python-wandb python-mlflow)
+optdepends=('ludwig-example: example use of Ludwig'
+ 'python-soundfile'
+ 'python-torchaudio'
+ 'python-scikit-image'
+ 'python-torchvision'
+ 'python-transformers'
+ 'uvicorn'
+ 'python-fastapi'
+ 'python-multipart'
+ 'python-imageio'
+ 'python-spacy'
+ 'python-seaborn'
+ 'python-horovod'
+ 'python-dask'
+ 'python-pyarrow'
+ 'python-ray'
+ 'python-tensorboardx'
+ 'python-gputil'
+ 'python-tblib'
+ 'aws-cli'
+ 'python-hyperopt')
+# neuropod python-sentencepiece python-hiplot python-petastorm python-pickle5 python-bayesmark python-pysot
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('dfb8100d726fd1ea6f3c472e805cc1e8ea7b272d62478280fded69ed45a5bfb2488f51088fa27bd2845fb8af8a219df305b2a5f742958b177fa972862bb03ae1')
build() {
- cd ludwig
+ cd "${_base}-${pkgver}"
python setup.py build
}
package() {
- cd ludwig
-
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
+ cd "${_base}-${pkgver}"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
# fix issue where spacy >= 2.0 is not detected
- find "$pkgdir" -name requires.txt -type f -exec sed -i '/spacy/d' {} \;
+ # find "$pkgdir" -name requires.txt -type f -exec sed -i '/spacy/d' {} \;
}
-
-# vim: ts=2 sw=2 et: