summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-18 14:18:09 +0100
committerAlexander F. Rødseth2019-03-18 14:18:09 +0100
commit7ea9ac48471c405c1c5777baa1847aae31b188f0 (patch)
tree7c57c51d5d2ba3586e30028a7e69726a69e001e6 /PKGBUILD
parentac930eec2a33d71fba17ba21982d658bc49caba6 (diff)
downloadaur-7ea9ac48471c405c1c5777baa1847aae31b188f0.tar.gz
Add dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5a14cdf2aea..adf599dea93b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=python-ludwig
pkgver=0.1.0
-pkgrel=2
+pkgrel=3
pkgdesc='Train and test deep learning models'
arch=(any)
url='https://github.com/uber/ludwig'
license=(MIT)
-depends=(cython python-h5py python-matplotlib python-numpy python-pandas python-scipy python-scikit-learn python-tqdm python-tabulate python-tensorflow python-yaml python-pytest python-scikit-image python-seaborn python-spacy-en_core_web_sm python-spacy)
+depends=(cython python-cloudpickle python-dask python-h5py python-matplotlib python-numpy python-pandas python-scipy python-scikit-learn python-tqdm python-tabulate python-tensorflow python-yaml python-pytest python-scikit-image python-seaborn python-spacy-en_core_web_sm 'python-spacy>=2.0')
makedepends=(git)
source=("git+https://github.com/uber/ludwig#tag=v$pkgver")
sha256sums=('SKIP')
@@ -21,6 +21,7 @@ package() {
cd ludwig
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ sed -i '/spacy/d' "$pkgdir/usr/lib/python"*"/site-packages/ludwig-$pkgver-*.egg-info/requires.txt"
}
# vim: ts=2 sw=2 et: