summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorD. Can Celasun2020-07-18 07:51:35 +0100
committerD. Can Celasun2020-07-18 07:51:35 +0100
commitd265076148530b820fa812097099c353c909dec6 (patch)
treea702f17b775d27427975bf49d31d9fedd9f256f3 /PKGBUILD
downloadaur-d265076148530b820fa812097099c353c909dec6.tar.gz
[python-lunr] Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1b8357c4332
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
+pkgname=python-lunr
+_pkgname=lunr
+pkgver=0.5.8
+pkgrel=1
+pkgdesc="A Python implementation of Lunr.js (for mkdocs)"
+arch=('any')
+url="https://pypi.org/project/mdx_gh_links/"
+license=('MIT')
+depends=('python-nltk>=3.2.5' 'python-future>=0.16.0' 'python-tqdm' 'python-joblib')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz")
+sha256sums=('c4fb063b98eff775dd638b3df380008ae85e6cb1d1a24d1cd81a10ef6391c26e')
+
+build() {
+ cd "${_pkgname}-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+