summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2024-03-20 04:19:36 +0800
committerlilac2024-03-20 04:19:36 +0800
commit4cb7c97cf6febdd2f9a19d20e0e3b86432354284 (patch)
tree14ab782b9d0aaa6d7e63a4a6dcbe1d36c3a9ef38 /PKGBUILD
parent10beff39186d8b4ba80c93bce78921e05e9fea76 (diff)
downloadaur-python-lvis-git.tar.gz
[lilac] updated to 0.5.3.r24.7d7f07d-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e2f8f14c4bc..aea759792ec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=python-lvis-git
_pkgname=lvis
_pkgver=0.5.3
-pkgver=0.5.3.r21.da5f65d
-pkgrel=1
+pkgver=0.5.3.r24.7d7f07d
+pkgrel=2
pkgdesc='Python API for LVIS Dataset'
arch=('any')
url='https://github.com/lvis-dataset/lvis-api'
-license=('BSD')
+license=('BSD-3-Clause')
depends=(
python-opencv
python-cycler
@@ -21,10 +21,13 @@ depends=(
python-six
)
makedepends=(
- git
cython
+ git
+ python-build
+ python-installer
python-pip
python-setuptools
+ python-wheel
)
checkdepends=(
hdf5
@@ -48,7 +51,7 @@ pkgver() {
build() {
cd "${_pkgname}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -58,7 +61,7 @@ check() {
package() {
cd "${_pkgname}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: