summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2015-09-30 10:03:10 +0200
committerRichard Neumann2015-09-30 10:03:10 +0200
commitd4b700fae529bee58a735ce4c5b40930229773e1 (patch)
tree8a9d489e952406912c81f958ebf9469974afbfbc /PKGBUILD
parent56084e7f94dd84f1134abc880fd5a6b3ed024664 (diff)
downloadaur-d4b700fae529bee58a735ce4c5b40930229773e1.tar.gz
Included original license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be430b017f70..18eba7248bd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,11 @@ srcdir='src'
package() {
local PYTHON="/usr/bin/env python3"
local USR_PATH="${pkgdir}/usr"
+ local LICENSE_DIR="${USR_PATH}/share/licenses/${pkgname}"
- # Set up /usr directory
+ # Set up directories
install -d -m 755 ${USR_PATH}
+ install -d -m 755 ${LICENSE_DIR}
# Clean up build dir
rm -Rf build
@@ -35,6 +37,9 @@ package() {
# Install python packages to $pkgdir
${PYTHON} setup.py install --prefix ${USR_PATH}
+ # Install license file
+ install -m 644 LICENSE ${LICENSE_DIR}
+
# Make directories accessible for anyone
find "${USR_PATH}" -type d -exec chmod 755 {} \;