summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlsf2017-02-17 22:28:53 +0100
committerlsf2017-02-17 22:28:53 +0100
commitbde5f8eb268b3715a56be020639f71398283a72c (patch)
treeb28839bb534bb43c354d8a0cf43203647044409d /PKGBUILD
downloadaur-bde5f8eb268b3715a56be020639f71398283a72c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0efd9581123e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : Christian Hofmann <chof@pfho.net>
+pkgname=python-malboxes-git
+_pkgname=malboxes
+pkgver=161.f0a6a97
+pkgrel=1
+pkgdesc="Builds malware analysis Windows VMs so that you don't have to."
+arch=('any')
+source='https://github.com/GoSecure/malboxes'
+license=('GPL')
+depends=('python' 'packer-io' 'virtualbox' 'vagrant' 'python-jsmin')
+makedepends=('python-pip' 'git')
+options=(!emptydirs)
+source=(git+https://github.com/GoSecure/malboxes.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ PIP_CONFIG_FILE=/dev/null pip3 install --isolated --root="$pkgdir" --ignore-installed --no-deps ./
+}
+
+# vim:set ts=2 sw=2 et: