summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Botting2017-04-12 16:54:53 +1000
committerAndy Botting2017-04-12 16:54:53 +1000
commitd3c763ab0c2b2a1a8ae65001f41f678171d110ed (patch)
tree902f30c38352f5a9d71ae12edc044709a0dddc83 /PKGBUILD
parent9f2e0176d9918daf531f6fbe31a9be5fbc584425 (diff)
downloadaur-d3c763ab0c2b2a1a8ae65001f41f678171d110ed.tar.gz
Update to v1.14.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 40 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc508d2b863e..89e82aa7becb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,66 @@
pkgname=('python-manilaclient' 'python2-manilaclient')
pkgver='1.14.0'
-pkgrel='1'
-pkgdesc='Python client library for Manila'
+pkgrel='2'
+pkgdesc='Client library for OpenStack Manila API'
arch=('any')
-url='http://docs.openstack.org/developer/python-manilaclient'
+url="http://docs.openstack.org/developer/${pkgname}"
license=('Apache')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("git+https://git.openstack.org/openstack/python-manilaclient#tag=$pkgver")
+makedepends=('git' 'python-setuptools' 'python2-setuptools')
+source=("git+https://git.openstack.org/openstack/${pkgname}#tag=${pkgver}")
+checkdepends=('python-pbr'
+ 'python-oslo-config'
+ 'python-oslo-log'
+ 'python-oslo-serialization'
+ 'python-oslo-utils'
+ 'python-prettytable'
+ 'python-requests'
+ 'python-simplejson'
+ 'python-babel'
+ 'python-six'
+ 'python-keystoneclient'
+ 'python-ddt'
+ 'python-fixtures'
+ 'python-mock'
+ 'python-oslotest'
+ 'python-testtools'
+ 'python-tempest')
md5sums=('SKIP')
prepare() {
- cp -a python-manilaclient{,-py2}
+ cp -a "${srcdir}/${pkgname}"{,-py2}
}
build() {
- cd "$srcdir"/python-manilaclient
+ cd "${srcdir}/${pkgname}"
python setup.py build
- cd "$srcdir"/python-manilaclient-py2
+ cd "${srcdir}/${pkgname}-py2"
python2 setup.py build
}
+check() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py testr
+
+ #cd "${srcdir}/${pkgname}-py2"
+ #PYTHON=python2 python2 setup.py testr
+}
+
package_python-manilaclient() {
depends=('python-oslo-config' 'python-oslo-log' 'python-oslo-serialization'
- 'python-oslo-utils' 'python-pbr' 'python-prettytable' 'python-requests'
- 'python-simplejson' 'python-babel' 'python-six' 'python-keystoneclient')
+ 'python-oslo-utils' 'python-pbr' 'python-prettytable'
+ 'python-requests' 'python-simplejson' 'python-babel' 'python-six'
+ 'python-keystoneclient')
cd "${srcdir}/${pkgname}"
python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-manilaclient() {
- depends=('python2-oslo-config' 'python2-oslo-log' 'python2-oslo-serialization'
- 'python2-oslo-utils' 'python2-pbr' 'python2-prettytable' 'python2-requests'
- 'python2-simplejson' 'python2-babel' 'python2-six' 'python2-keystoneclient')
+ depends=('python2-oslo-config' 'python2-oslo-log'
+ 'python2-oslo-serialization' 'python2-oslo-utils' 'python2-pbr'
+ 'python2-prettytable' 'python2-requests' 'python2-simplejson'
+ 'python2-babel' 'python2-six' 'python2-keystoneclient')
cd "${srcdir}/python-manilaclient-py2"
python2 setup.py install --root="${pkgdir}" --optimize=1
mv "${pkgdir}"/usr/bin/manila{,2}