summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Kazimiers2023-11-22 22:45:52 +0100
committerTom Kazimiers2023-11-23 16:25:12 +0100
commit4da111f15de49e1fdcfd5bf390a10703bfb4ce93 (patch)
tree2101b9726d6af455b482f377de7df719ed46a8e0 /PKGBUILD
parentb83724d0771eb754a538899510118d2f8c1b1e19 (diff)
downloadaur-4da111f15de49e1fdcfd5bf390a10703bfb4ce93.tar.gz
Fix compilation problems
Most patches are taken from the Ubuntu repository: https://salsa.debian.org/debian-gis-team/python-mapnik
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 25 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45450076f841..fc252a1444d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,42 @@
pkgname=python-mapnik
pkgver=3.0.16
-pkgrel=2
+pkgrel=3
pkgdesc="Python3 bindings for Mapnik"
url="https://github.com/mapnik/python-mapnik"
arch=('any')
license=('LGPL')
-depends=('python' 'mapnik' 'python-cairo' 'python-pypdf2')
+depends=('python' 'mapnik' 'python-cairo' 'python-pyarrow' 'python-pypdf2')
makedepends=('python-setuptools')
-source=("https://github.com/mapnik/python-mapnik/archive/v$pkgver.tar.gz")
-sha1sums=('8e30049954b14282667677a5d5a145eddedfc8df')
+source=("https://github.com/mapnik/python-mapnik/archive/v$pkgver.tar.gz"
+ "package.patch"
+ "proj6-apis.patch"
+ "proj6-syntax.patch"
+ "no-distutils.patch"
+ "boost1.71.patch")
+sha1sums=('8e30049954b14282667677a5d5a145eddedfc8df'
+ 'b85f58f54a3353fbb51df79ea4d337f3b299cac7'
+ 'da86ea6a077a0eee051342a8ac8dab72a3f0b5c0'
+ 'bf4118f8770c8a6ebfe144fbd8293c461de63ac8'
+ '57272b7d7424c9f1b9650305738f46dd1d757348'
+ '3a595137ebf04e96b18b672ce1aa0e20bcb72ee2')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ rm "src/mapnik_svg_generator_grammar.cpp"
+ patch --forward --strip=1 --input="${srcdir}/package.patch"
+ patch --forward --strip=1 --input="${srcdir}/proj6-apis.patch"
+ patch --forward --strip=1 --input="${srcdir}/proj6-syntax.patch"
+ patch --forward --strip=1 --input="${srcdir}/no-distutils.patch"
+ patch --forward --strip=1 --input="${srcdir}/boost1.71.patch"
+}
package() {
+ echo "Proj4 support is enabled, but requires a mapnik version where this is enabled as well."
cd python-mapnik-$pkgver
export PYCAIRO_NO_IMPORT
python setup.py install --root="$pkgdir" --optimize=1
}
-