summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormidn8hustlr2024-03-19 02:21:42 +0530
committermidn8hustlr2024-03-19 02:21:42 +0530
commitd40e11793f944db3d4901528262df47d16b2267c (patch)
tree6c8d8e488fc8fd12b03e737b7949ba4a53de94a8 /PKGBUILD
downloadaur-d40e11793f944db3d4901528262df47d16b2267c.tar.gz
Creating initial AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcb8f4ba37ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: avi <4visekh@gmail.com>
+pkgname=python-materialyoucolor-git
+_name=materialyoucolor-python
+pkgver=v2.0.7.r5.g1dd2f05
+pkgrel=1
+pkgdesc="Material You color algorithms for Python!"
+arch=('x86_64')
+url="https://github.com/T-Dynamos/materialyoucolor-python"
+license=('MIT')
+depends=('glibc' 'gcc-libs' 'python' 'python-pillow')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_name
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_name
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}