summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDylan Delgado2024-01-16 13:42:03 -0500
committerDylan Delgado2024-01-16 13:42:03 -0500
commitd39625a38db67146d8b51e7ed1cf3202139797c6 (patch)
tree1fe7497627a8e998f5f7d7b1012253a1fe0cf7ac /PKGBUILD
parent93cba715e8625b2cbc71de1836221ae447454632 (diff)
downloadaur-d39625a38db67146d8b51e7ed1cf3202139797c6.tar.gz
Convert to standards-based install, fix env issue, wxpython package fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 13 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 242d0cb05b63..fe11ab0a2053 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# $Id$
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Maintainer: Dylan Delgado <dylan1496@live.com>
+# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=python-matplotlib-git
-pkgver=r26679.b9b02f189
+pkgver=r49400.d0575d486f
pkgrel=1
pkgdesc="A python plotting library for making publication quality plots, master git branch"
arch=('i686' 'x86_64')
@@ -16,10 +17,10 @@ makedepends=('rsync' 'git' 'python-pytz' 'python-numpy'
'tk' 'python-cairocffi' 'python-dateutil'
'python-gobject' 'python-pyparsing'
'pygtk' 'python-six' 'ghostscript' 'texlive-bin'
- 'python-tornado' 'gtk3' 'wxpython' 'python-pyqt5'
+ 'python-tornado' 'gtk3' 'python-wxpython' 'python-pyqt5'
'libxkbcommon-x11' 'python-pillow' 'python-setuptools'
- 'python-cycler')
-source=("git+git://github.com/matplotlib/matplotlib.git#branch=master" setup.cfg)
+ 'python-cycler' "pybind11" 'python-build' 'python-installer' 'python-wheel' 'meson-python')
+source=("git+https://github.com/matplotlib/matplotlib.git#branch=main" setup.cfg)
md5sums=('SKIP'
'5fa7d3c374ec049e3ed592ddff0111be')
@@ -32,7 +33,7 @@ prepare() {
cd "$srcdir"/matplotlib
for file in $(find . -name '*.py' -print); do
sed -i -e "s|^#!.*/usr/bin/python|#!/usr/bin/python3|" \
- -e "s|^#!.*/usr/bin/env *python|#!/usr/bin/env python3|" ${file}
+ -e "s|^#!.*/usr/bin/env *python|#!/usr/bin/env python|" ${file}
done
rsync -a "$srcdir"/matplotlib/ "$srcdir"/matplotlib-test --exclude '.git'
@@ -47,25 +48,17 @@ build() {
export XDG_RUNTIME_DIR=/tmp
cd "$srcdir"/matplotlib
- python3 setup.py build
+ python -m build --wheel --no-isolation
}
check() {
- cd "$srcdir"/matplotlib-test
- python3 setup.py build
+ cd "$srcdir"/matplotlib
- cd "$srcdir"/matplotlib-test
- (
- export PYTHONPATH="$PWD/build/lib.linux-$CARCH-3.5:$PYTHONPATH"
- python -c "from matplotlib import font_manager"
- rm -rf ../tmp_test_dir && mkdir ../tmp_test_dir && cd ../tmp_test_dir
- xvfb-run -a -s "+extension GLX +extension RANDR +render -screen 0 1280x1024x24" \
- python ../matplotlib/tests.py -sv --processes=8 --process-timeout=300 || warning "Tests failed"
- )
+ pytest
}
package() {
- depends=('python-pytz' 'python-numpy' 'python-pyqt5' 'python-dateutil' 'python-pyparsing' 'python-cycler' 'libxkbcommon-x11')
+ depends=('python-kiwisolver' 'python-pytz' 'python-numpy' 'python-pyqt5' 'python-dateutil' 'python-pyparsing' 'python-cycler' 'libxkbcommon-x11')
optdepends=('python-gobject: for GTK3Agg/GTK3Cairo backend'
'python-cairocffi: for GTK3Agg/GTK3Cairo backend'
'python-pyqt4: for Qt4Agg backend'
@@ -78,8 +71,8 @@ package() {
conflicts=('python-matplotlib' 'python-matplotlib2')
cd matplotlib
- python3 setup.py install -O1 --skip-build --root "${pkgdir}" --prefix=/usr
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -dm755 "${pkgdir}"/usr/share/licenses/python-matplotlib
- install -m 644 doc/users/license.rst "${pkgdir}"/usr/share/licenses/python-matplotlib
+ install -m 644 doc/users/project/license.rst "${pkgdir}"/usr/share/licenses/python-matplotlib
}